Başlangıç / Cisco / Cisco Network / Vlan and Router configuration….

Vlan and Router configuration….

Vlan and Router configuration….

İki farklı Network ID sinin bir birleri ile konuşturmak.

Gerekenler ;

3 adet switch’e sahip olmalıyız.

Bunlardan 1. Server Switch Diğer 2’si Client Switch olacaklar biçimde tanımlayacağız. Şekil 1 de görüldüğü gibi…

Şekil 1

İlk olarak Router’ımızın İsmini ve güvenlik ayarlarını yapılandırarak işlemlere başlayalım…

Bununlar için gerekli komutlar.

Router>enable

Router#configure terminal

Router(config)#hostname SARIDIKMEN

SARIDIKMEN(config)#enable password savas

SARIDIKMEN(config)#line vty 0 4

SARIDIKMEN(config-line)#login

SARIDIKMEN(config-line)#password savas

SARIDIKMEN(config-line)#exit

SARIDIKMEN(config)#do wr

Şekil 2

Telnet üzerinden yapılacak bağlantılar içinde güvenlik önlemimizi aldık.

Bundan sonraki aşamalar ise ….

İlk olarak Server Switch’imizi oluşturalım.

Bunlar için gerekli komutlar ;

Switch>enable

Switch#conf terminal

Switch(config)#hostname SERVERSWITCH

SERVERSWITCH(config)#enable password savas

SERVERSWITCH(config)#line vty 0 4

SERVERSWITCH(config)#login

SERVERSWITCH(config)#password savas

SERVERSWITCH(config)#exit

SERVERSWITCH#vlan database

SERVERSWITCH(vlan)#vtp domain savas

Changing VTP domain name from NULL to savas

SERVERSWITCH(vlan)#vtp server

Device mode already VTP SERVER.

SERVERSWITCH(vlan)#vtp password savas

Setting device VLAN database password to savas

SERVERSWITCH(vlan)#exit

SERVERSWITCH#conf ter

SERVERSWITCH(config)#do wr

SERVERSWITCH(config)#vlan 10

SERVERSWITCH(config-vlan)#name MUHASEE

SERVERSWITCH(config-vlan)#exit

SERVERSWITCH(config)#vlan 20

SERVERSWITCH(config-vlan)#name WEB

SERVERSWITCH(config-vlan)#exit

SERVERSWITCH(config)#do wr

Şekil 3 de görüldüğü gibi VLAN larımız oluşturuldu.

Şekil 3

Server Switch ayarlarımızı tamamladık ve diğer geri kalan 2 Switch Client larımızı yapılandıralım…

Switch(vlan)#vtp domain savas

Changing VTP domain name from NULL to savas

Switch(vlan)#vtp cli

Switch(vlan)#vtp client

Setting device to VTP CLIENT mode.

Switch(vlan)#vtp password savas

Setting device VLAN database password to savas

Bu işlemi yaptıkdan sonra SERVER SWITCH den CLIENT SWITCH’e giden portda ( Port 1 )

Bu Switch’ler arasındaki haberleşmeyi sağlamak için trunk komutunu çalıştırmamız gerekiyor bu işlemi her iki Switch’in bağlı oldukları portlardan karşılıklı yapmak gerekiyor. Bunu yapmak için gerekli komutlar;

SERVER

SERVERSWITCH#conf ter

SERVERSWITCH(config)#int f 0/1

SERVERSWITCH(config-if)#switchport mode trunk

CLIENT

Switch#conf ter

Switch(config)#int f 0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#exit

Switch(config)#do wr

Şekil 4 de görüldüğü gibi CLIENT SWITC de VLAN larımızı görebiliyoruz.

Şekil 4

Bu işlemleri Diğer CLIENT SWITCH de de yapalım ve VLAN yapımızı Router kurulumumuz dışında tamamlamış olalım…

witch(vlan)#vtp domain savas

Domain name already set to savas.

Switch(vlan)#vtp client

Device mode already VTP CLIENT.

Switch(vlan)#vtp password savas

Password already set to savas

Switch(vlan)#exit

Switch#conf ter

Switch(config)#int f 0/24

Switch(config-if)#switchport mode trunk

Şimdi sıra ROUTER’ımızı yapılandırmamıza geldi 2 farklı networkde birbirleri ile konuşmamızı sağlayacak router yapılandırmamız için gerekli komut satırı ;

SARIDIKMEN>EN

Password:

SARIDIKMEN#conf ter

SARIDIKMEN(config)#int f 0/0.1

SARIDIKMEN(config-subif)#encapsulation dot1Q 10

SARIDIKMEN(config-subif)#ip address 192.168.16.100 255.255.255.0

SARIDIKMEN(config-subif)#do wr

SARIDIKMEN(config-subif)#exit

SARIDIKMEN(config)#int f 0/0.2

SARIDIKMEN(config-subif)#encapsulation dot1Q 20

SARIDIKMEN(config-subif)#ip address 192.168.2.100 255.255.255.0

SARIDIKMEN(config-subif)#do wr

SARIDIKMEN(config)#exit

SARIDIKMEN#conf ter

SARIDIKMEN(config)#int f 0/0

SARIDIKMEN(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up

%LINK-5-CHANGED: In

%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to up

Şekil 5

İşlem tatmamdır. Bir dahaki makalede tekrar görüşmek üzere hoşçakalın..

Hakkında: Mustafa HAMİT

Kontrol Ediliyor

Subnetting Alt Ağlara Bölme

Mevcut network yapısı genişleyince broadcast etki alanı da büyüyecek ve tüm networkeki bilgisayarlar yoğun bir …

IP nedir nasıl üretilir?

IP adresi cihazların networkteki adresidir. Örneğin; bir arkadaşınızın evine gitmek istiyorsunuz, evini size tarif ederken …

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir